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Sonos Controller App for Mac or PC
• Lets you control all your music and rooms from any desktop or laptop computer in your house. 
• Simply install the software and follow the prompts to guide you through setup and music sharing. You can download 

the software at www.sonos.com/support. 

Already have Sonos?

If you are adding an Sonos Controller for Mac or PC to an existing Sonos system, please see "Adding a Sonos Controller for 
Mac or PC" on page 1-6 for more information.

Note: The Sonos Controller for Mac or PC requires that you have an Mac or PC, one or more 
Sonos players, and a wireless router set up in your home. Macs, PCs, and Sonos products are 
sold separately.

New to Sonos?

It takes just a few steps to get your Sonos system up and running. Unpack the Sonos products you purchased and refer to 
the Quickstart Guide included in the box. Once you’ve set up your Sonos system, you can easily download and install the 
Sonos Controller for Mac or PC. The Sonos Controller for Mac is compatible with Macintosh® OS X® 10.6.8 and higher. The 
Sonos Controller for PC is compatible with Windows® XP SP3 and higher.
Chapter 1

http://www.sonos.com/support
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For additional help, please visit our website at www.sonos.com/support/guides to view the latest product documentation.

Your Home Network
To access Internet music services, Internet radio, and any digital music stored on your computer or Network-Attached Stor-
age (NAS) device, your home network must meet the following requirements:

Home network requirements

• High-speed DSL/Cable modem, or fiber-to-the-home broadband connection for proper playback of Internet-based 
music services. (If your Internet service provider only offers Satellite Internet access, you may experience playback 
issues due to fluctuating download rates.)

• If your modem is not a modem/router combination and you want to take advantage of Sonos' automatic online 
updates, or stream music from an Internet-based music service, you must install a router in your home network. If 
you do not have a router, purchase and install one before proceeding. If you are going to use the Sonos Controller App 
on an Android™ or iOS device, or you are setting up Sonos wirelessly, you will need a wireless router. Please visit our 
Web site at http://faq.sonos.com/apps for more information.

Note: Sonos communicates over a 2.4GHz home network supporting 802.11 b/g wireless 
technology. 5GHz networks are not supported in a completely wireless Sonos setup.

Note: Your network must have a high-speed Internet connection, as the Sonos system is 
designed to provide you with free, online software updates. Your Sonos system must be 
registered to receive these updates so be sure to register during the setup process. We do 
not share your e-mail address with other companies.

http://www.sonos.com/support/guides
http://faq.sonos.com/apps
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• Connect a Sonos BRIDGE, BOOST or player to your router if: 
• You have a larger home where the WiFi performance isn’t reliable and you want to strengthen the wireless perfor-

mance of your Sonos system.
• Your WiFi network is already in high demand with streaming video and web surfing and you want to create a sepa-

rate wireless network exclusively for your Sonos speakers.
• You want to pair a SUB™ and/or a pair of PLAY:1® or PLAY:3™ speakers with your PLAYBAR® to create a 3.1 or 5.1 

home theater setup.
• Your home network is 5GHz only (not switchable to 2.4GHz).

• For best results, you should connect the computer or NAS drive that contains your personal music library collection to 
your home network router using an Ethernet cable. 

System requirements

• 500 MHz processor or better 
• 128 MB RAM minimum/256 MB RAM recommended 
• Network hardware as described above

Compatible operating systems

• Windows® XP SP3 and higher (while Windows XP SP3 and higher are compatible with version 5.1, standard wireless 
setup is only supported on Windows 7 and higher)

• Macintosh® OS X 10.6.8 and higher (while Macintosh OS  X 10.6.8 and higher are compatible with version 5.1, standard 
wireless setup is only supported on Mac iOS 10.7 and higher)

Compatible music services

• 7 Digital©

• 8 Tracks©

• Amazon Cloud Player
• AUPEO!
• Batanga©

• Beats Music
• blinkbox® music
• Calm Radio
• Concert Vault®
• Dar.fm® Record Radio
• Daytrotter
• Deezer
• 豆瓣 FM (DoubanFM)
• 多米音乐 (Duomi)
• Google Play Music
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• Grooveshark
• Hearts of Space®
• hotelradio.fm™
• iHeartRadio
• JB Hi-Fi NOW
• JUKE
• Last.fm™
• Live365
• MLB.com Gameday Audio
• Murfie
• Napster by Rhapsody
• Netease
• Pandora®
• Qobuz
• QQ 音乐 (QQ Music)
• radionomy
• rara.com
• Rdio™
• Rhapsody®
• RUSC
• Shuffler.fm
• simfy®
• SiriusXM® Internet Radio
• Slacker
• Songl
• Songza©

• SoundCloud®
• Spotify®
• Stitcher SmartRadio™
• TDC Play Musik©

• The Hype Machine©

• TuneIn
• WiMP
• Xiami
• YouMusic©

• Zdigital
• and downloads from any service offering DRM-free tracks
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Sonos is always adding new music services. Just remember that Sonos is compatible with any download service that provides 
DRM-free tracks. For the latest list of compatible music services, you can visit our Web site at www.sonos.com/music. 

Compatible playlist formats

• iTunes®
• Musicmatch™
• Rhapsody®
• Windows Media® Player 
• WinAmp®

Compatible audio formats

• MP3
• WMA
• AAC (MPEG4)
• AAC+
• iTunes Plus
• Ogg Vorbis
• Audible .AA files (format 4)
• Apple Lossless
• Flac (lossless) 
• Uncompressed WAV and AIFF files
• Native support for 44.1kHz sample rates. Additional support for 48kHz, 32kHz, 24kHz, 22kHz, 16kHz, 11kHz, and 8kHz 

sample rates. 
Previously purchased Apple “Fairplay” DRM-protected songs may need to be upgraded. See Apple for details. WMA Lossless 
formats not currently supported.

Compatible streaming formats

• MP3
• WMA
• AAC

Note: For the latest system requirements, including supported operating system versions, 
please visit our Web site at http://faq.sonos.com/specs.

Compatible screen reader software

• JAWS® for Windows® screen reading software

http://www.sonos.com/music
http://faq.sonos.com/specs
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Getting Started
Adding a Sonos Controller for Mac or PC

Download the Sonos Controller App to a Mac or PC that’s connected to your wireless network (Sonos Controller App use 
requires you have at least one Sonos player set up in your home). The Sonos Controller for Mac is compatible with Macin-
tosh® OS X® 10.6.8 and higher. The Sonos Controller for PC is compatible with Windows® XP SP3 and higher.
For information on when to use a wireless router with your Sonos system, please visit our website at 
http://faq.sonos.com/apps.

Note: To use the Sonos Controller App, your Mac or PC, must be connected to your wireless 
network and the Wi-Fi setting must be turned on.

1. Go to www.sonos.com/install to download the free Sonos Controller for Mac or Sonos Controller for PC.

Note: During installation, you may see prompts from your firewall software indicating that 
the Sonos application is attempting to perform certain operations. You should always allow 
full access to the Sonos Controller App for Mac or PC. You may also need to change the 
settings of your firewall software to ensure that Windows file sharing is not blocked. For 
detailed instructions, please go to our Website at http://faq.sonos.com/firewall.

2. Double-click the Sonos  icon and follow the prompts to add the Sonos Controller app to your Sonos system. During 
setup you will be prompted to press the button(s) on one of your Sonos products:

• Sonos BRIDGE. Press the Join button on top. 
• Sonos BOOST or SUB. Press the Join button on the side. 
• Sonos Players. Press the Play/Pause and Volume Up buttons simultaneously (releasing as soon as the status indicator 

starts to blink.) 
If you need assistance, please go to our website at www.sonos.com/support. 

Adding a household

Your Sonos Controller App for Mac or PC gives you quick and easy access to all of your Sonos systems. Simply add a house-
hold to your Sonos Controller App and it will automatically connect as you move from one place to another. So, enjoy your 
Sonos system at work, and when you get home, open your Sonos controller for instant access to your music. The Sonos 
Controller App for Mac or PC supports up to 100 households.

• Double-click the Sonos  icon, and then click Add Another Sonos System.

Note: You can remove a household from your Sonos Controller App by selecting Settings -> 
Advanced Settings -> Forget Current Sonos System.

http://faq.sonos.com/apps
www.sonos.com/install
http://faq.sonos.com/firewall
http://www.sonos.com/support
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Wireless Setup
If you currently have a Sonos product wired to your router and you’d like to switch to wireless setup, follow the steps below. 
Switching to wireless setup may be desirable if you currently have a player connected to your router and you’d like to move it 
to another room. If you have a BRIDGE or BOOST connected to your router, we recommend leaving it connected.
DO NOT DISCONNECT the Sonos product that is currently connected to your router until you complete the wireless 
setup steps below.

1. Choose one of the following options:

• Using the Sonos Controller App for PC: Select Settings -> Advanced from the Manage menu. On the General tab, select 
Wireless Setup.

• Using the Sonos Controller App for Mac: Select Preferences -> Advanced from the Sonos menu. On the General tab, 
select Wireless Setup.

Sonos will detect your wireless network. 
2. Enter the password for your wireless network.

3. Once the password has been accepted, you can remove the Sonos product from the router and move it to a new location.

Technical Support
Whatever you need, our Sonos Support team is just an email or live support chat away. 

• Email: support@sonos.com
• Web site: www.sonos.com/support

Visit our Forums, browse our Frequently Asked Questions (FAQ) pages, or request assistance.
• Live Text-Chat and Telephone Numbers: www.sonos.com/support/contact

Live chat or find the correct telephone number for your country.

System Registration
Registering your music system allows you to receive technical support, Sonos software upgrades, and several free music 
service trials. At no time is any of your information provided to other companies.
Select Sonos System Registration from the Help menu.

mailto: support@sonos.com
http://www.sonos.com/support
http://www.sonos.com/support/contact


Sonos App for PC
The Sonos Controller for PC software is compatible with Windows® XP SP3 and higher operating systems. (For the latest 
system requirements and compatible audio formats, visit our Web site at http://faq.sonos.com/specs.)
For easy setup, you should install the Sonos Controller for PC software on every Windows computer in your network that 
contains music files. However, if you wish to access music stored on a computer where file sharing is not yet enabled and the 
Sonos Controller for PC software is not installed, you can go to our Web site at http://faq.sonos.com/sharing. 

Tour the Sonos Controller for PC App

You can choose music by selecting a music source from the MUSIC pane, select a category (such as Artists, Albums, or 
Composers), and then drilling down through the selected source, or you can search for music in a specific source. 
Chapter 2

http://faq.sonos.com/sharing for assistance
http://faq.sonos.com/specs
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Navigation

Now Playing screen 
The Now Playing pane displays information about the audio that is currently playing in the selected room, playback controls, 
and so on.

MUSIC Click MUSIC to browse or select music, or access playlists.

Back Click  to return to the previous screen.

Info & Options Click  to display additional options, such as adding a track to your 
Sonos Favorites or viewing artist/album information. The information 
appears in the MUSIC pane.

Playback Controls

You can control the music settings for the current selection using the playback controls below. The track position slider 
allows you to move quickly backward or forward through the current track by dragging the slider. 

Play / Pause Toggles between playing and pausing the current track. 

Next / Fast Forward Jumps to the start of the next track in the queue; click and hold down 
button, or click and drag progress bar to fast forward.

Previous / Rewind Jumps to the start of the current track, if you are more than 3 seconds 
into the track; jumps to the start of the previous track, if you are less 
than 3 seconds into the track.
Click and hold down the button to rewind within the current track. When 
you release the button, playback resumes at the new location.

Note: You can control playback by pressing the media keys on your keyboard. You can also 
use keyboard shortcuts. For a list of keyboard shortcuts, select Help -> Keyboard Shortcuts.

Queue Controls

Repeat Repeats the music queue after the last track has finished.
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You can also copy the metadata for a track by highlighting the track in the queue, and then selecting Edit -> Copy. You can 
paste this content into the Search box on your Sonos Controller for PC, into an online search engine, and so on.

Volume Control

• Click and drag the volume control to the right to increase the volume, or to the left to decrease the volume. If rooms 
are grouped, adjust the volume across the group using the volume slide at the top, or adjust the volume in one room 
using the individual slide. When headphones are plugged in, a headphone icon is visible in the volume display. If you 
don’t hear sound coming from your PLAY:5®, check to make sure there are no headphones plugged into the unit. If you 
adjust group volume, the volume for the component with headphones attached will be unaffected.

• Mute temporarily silences the music in a room (for a group, all rooms in the group are affected). From the ROOMS pane, 
click to highlight the room or group you want to mute, and then click the Mute button. To mute one room in a group, 
click the volume slide and then click the Mute button for the room. To unmute, click the Mute button again.

Note: A headphone indicator  appears on the Volume screen when headphones are 
plugged in to a PLAY:5. If you adjust group volume, the volume for the PLAY:5 with 
headphones attached is unaffected.

 

Clock and Alarms
Setting date and time

1. From the Manage menu, select Settings -> Date and Time.

2. Select your time zone, date format, and time format.

3. Select the Adjust for Daylight Savings Time checkbox, as needed.

Shuffle Plays the tracks in the music queue in a random order.

Crossfade Fades out the current track while fading in the next track to create a 
smooth transition between tracks.
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4. Choose one of the following options:

• To set the date and time from the Internet, select the Set the date and time from the Internet checkbox. Your Sonos 
system will periodically update the date and time from the Internet. 

• Or, set the date and time manually (Set the date and time from the Internet must be off for this option to be avail-
able). 

Adding an alarm

1. Click Alarms, and then click Add.

2. Choose the desired settings for this alarm, including the alarm time, the room you would like the alarm to play in, the 
music source you’d like to play from, the frequency of the alarm, and the volume and duration.

• If you check Include grouped rooms, the alarm will play in the rooms that are grouped together at the time the alarm 
goes off. It does not play in the rooms that were grouped when the alarm was originally added to the Sonos system.

• If you check Shuffle music, the play mode for the selected alarm music will be set to shuffle.
3. Click OK.

4. Select the ON checkbox for the alarm you want to turn on.

Note: If the music you’ve selected is not available when the alarm goes off (such as an 
Internet radio station that has dropped off), your alarm plays the Sonos chime instead.

Setting an alarm

• Click Alarms, and then select the ON checkbox for the alarm you want to turn on.

Note: You can also turn on an alarm when adding or editing it.

Changing an alarm

1. Click Alarms, select an alarm from the list, and then click Edit.

2. Make the desired changes.

• If you check Include grouped rooms, the alarm will play in the rooms that are grouped together at the time the alarm 
goes off. It does not play in the rooms that were grouped when the alarm was originally added to the Sonos system.

• If you check Shuffle music, the play mode for the selected alarm music will be set to shuffle.
3. Click OK.

Deleting an alarm

1. Click Alarms.

2. Select the alarm you wish to delete, and then click Remove.
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Setting a sleep timer

1. Click Sleep Timer.

2. Select the desired time frame.

3. If you wish to turn the sleep timer off, select Off from the list.

When a sleep timer is active, the time displays next to Sleep Timer.

Turning off an alarm

When the alarm goes off, click  to turn it off.

Software Updates
Sonos provides software updates for your music system in order to improve performance and add features. Your Sonos 
system must be registered to receive updates. If you have not yet registered, go to http://faq.sonos.com/register for help 
with this step.

Setting software update preferences

There are two options available: 
• Periodically check for updates. When there is a software update available, an alert will appear when you start the Sonos 

Controller for PC software. 
• Do not check for updates.

1. From the Manage menu, select Settings -> Advanced.

2. On the General tab, select the Automatically check for updates check box if you want the Sonos system to check 
periodically for a newer version of the software.

Downloading software updates

When there is an update available,  Update Now appears in the MUSIC pane. 

1. Click  Update Now to begin the update process. 

You can also check for software updates by selecting Check for Software Updates from the Manage menu.
2. If there are updates available, click Next to download.

• Your Sonos products will all be updated as they must carry the same software version number. This process may take 
several minutes per device, depending upon your network connection. The Sonos Controller for PC will automatically 
close and then re-open during the update process. 

Important Note: Do not disconnect power from your Sonos product(s), or in any way disable 
your Sonos system while this process is running. Contact Sonos Customer Support if an error 
occurs.

http://faq.sonos.com/register
http://faq.sonos.com/register
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• Software updates to a handheld Sonos Controller must be initiated from that Controller, so if you have recently updated 
the Sonos Controller for PC software, you will be prompted to update your other Sonos controllers the next time you 
use them. Simply follow the on-screen prompts.

• If your software is up to date, the message “Your Sonos system is up to date. No Updates are Required.” will appear 
instead.

• One or more Sonos products may need to be updated when you purchase a new Sonos product with a later software 
version, or if you plug in a Sonos product that was not in use when you performed your last software update. If a prod-
uct’s software version gets out of sync with the rest of your Sonos system, a message will display in the ROOMS pane. 
Click the outdated room to begin the software update process.

For additional information, go to http://faq.sonos.com/updateerror.

Beta Programs
Sonos lets customers try out pre-release beta software to test new features and help us improve our products. While you are 
running beta software, usage data sharing is automatically turned on. 

1. From the Manage menu, select Settings -> Advanced.

2. On the Improve Sonos tab, click Beta Program, and then follow the on-screen prompts.

Language Preference
1. From the Manage menu, select Change Language.

2. Select a new language, and then click Restart Controller.

Firewall Information
The Sonos Wireless HiFi System is designed to work with most firewall software. You will be prompted during setup to allow 
access to Sonos—be sure to allow access to Sonos when prompted or the Sonos system will not operate correctly. For the 
latest firewall information, go to http://faq.sonos.com/firewall.
You can also contact Sonos Technical Support at www.sonos.com/support.

http://faq.sonos.com/firewall
http://www.sonos.com/support
http://faq.sonos.com/updateerror


Sonos App for Mac
The Sonos Controller for Mac is compatible with Macintosh OS X, version 10.6 or later. (For the latest system requirements 
and compatible audio formats, you can visit our Web site at http://faq.sonos.com/specs.)
For easy setup, you should install the Sonos Controller for Mac software on every Macintosh computer in your network that 
contains music files. During the setup process, you may be asked to configure your Macintosh’s firewall for Sonos. Also, if 
your Macintosh computer does not have Windows Sharing enabled, the Sonos Controller for Mac will guide you through the 
process of enabling it. 

Tour the Sonos Controller for Mac App 

You can choose music by selecting a music source from the MUSIC pane, select a category (such as Artists, Albums, or 
Composers), and then drilling down through the selected source, or you can search for music in a specific source. 
Chapter 3
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Navigation

Now Playing screen
The Now Playing pane displays information about the audio that is currently playing in the selected room, playback controls, 
and so on.

MUSIC Click MUSIC to browse or select music, or access playlists.

Back Click  to return to the previous screen.

 Info & Options Click  to display additional options, such as adding a track to your 
Sonos Favorites or viewing artist/album information. The information 
appears in the MUSIC pane.

Playback Controls

You can control the music settings for the current selection using the playback controls below. The track position slider 
allows you to move quickly backward or forward through the current track by dragging the slider.

Play / Pause Toggles between playing and pausing the current track. 

Next / Fast Forward Jumps to the start of the next track in the queue; click and hold down 
button, or click and drag progress bar to fast forward.

Previous / Rewind   Jumps to the start of the current track, if you are more than 3 seconds 
into the track; jumps to the start of the previous track, if you are less 
than 3 seconds into the track.
Click and hold down the button to rewind within the current track. When 
you release the button, playback resumes at the new location.

Note: You can also control playback using the media keys on your keyboard or keyboard 
shortcuts. For a list of keyboard shortcuts, select Help -> Keyboard Shortcuts.
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Queue Controls

Repeat Repeats the music queue after the last track has finished.

Shuffle Plays the tracks in the music queue in a random order.

Crossfade Fades out the current track while fading in the next track to create a 
smooth transition between tracks.

Volume Control

• Click and drag the volume control right to increase volume, or left to decrease volume. If rooms are grouped, adjust the 
volume across the group using the volume slide at the top, or adjust the volume in one room using the individual slides. 
When headphones are plugged in, a headphone icon is visible in the volume display. If you don’t hear sound coming 
from your PLAY:5, check to make sure there are no headphones plugged into the unit. If you adjust group volume, the 
volume in the room with headphones attached will be unaffected.

• Mute temporarily silences the music in a room (for a group, all rooms in the group are affected). From the ROOMS pane, 
click to highlight the room or group you want to mute, and then click the Mute button. To mute one room in a group, 
click the volume slide and then click the Mute button for the room. To unmute, click the Mute button again.

Note: A headphone indicator  appears on the Volume screen when headphones are 
plugged in to a PLAY:5. If you adjust group volume, the volume for the PLAY:5 with 
headphones attached is unaffected.
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Clock and Alarms
Setting date and time

1. From the Sonos menu, select Preferences -> Date and Time.

2. Select your time zone, date format, and time format.

3. Select the Adjust for Daylight Savings Time checkbox, as needed.

4. Choose one of the following options:

• To set the date and time from the Internet, select the Set the date and time from the Internet checkbox. Your Sonos 
system will periodically update the date and time from the Internet. 

• Or, set the date and time manually (Set the date and time from the Internet must be off for this option to be avail-
able). 

Adding an alarm

1. Click Alarms and then click . 

2. Choose the desired settings for this alarm, including the alarm time, the room you would like the alarm to play in, the 
music source you’d like to play from, the frequency of the alarm, and the volume and duration.

• If you check Include grouped rooms, the alarm will play in the rooms that are grouped together at the time the alarm 
goes off. It does not play in the rooms that were grouped when the alarm was originally added to the Sonos system.

• If you check Shuffle music, the play mode for the selected alarm music will be set to shuffle.
3. Click OK.

Note: If the music you’ve selected is not available when the alarm goes off (such as an 
Internet radio station that has dropped off), your alarm plays the Sonos chime instead.

Setting an alarm

To turn on an alarm:
• Click Alarms, and then select the checkbox next to the alarm you want to turn on.

Note: You can also turn on an alarm when adding or editing it.

Changing an alarm

1. Click Alarms, select an alarm from the list, and then click Edit.

2. Make the desired changes.

• If you check Include grouped rooms, the alarm will play in the rooms that are grouped together at the time the alarm 
goes off. It does not play in the rooms that were grouped when the alarm was originally added to the Sonos system.

• If you check Shuffle music, the play mode for the selected alarm music will be set to shuffle.
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3. Click OK.

Deleting an alarm

1. Click Alarms.

2. Select the alarm you wish to delete, and then click .

Setting a sleep timer

1. Click Sleep Timer.

2. Select the desired time frame.

3. If you wish to turn the sleep timer off, select Off from the list.

When a sleep timer is active, the duration displays next to Sleep Timer.

Turning off an alarm

When the alarm goes off, click  to turn it off.

Software Updates
Sonos provides software updates for your music system in order to improve performance and add features. Your Sonos 
system must be registered to receive updates. If you have not yet registered, go to http://faq.sonos.com/register for help 
with this step. 

Setting software update preferences

There are two options available: 
• Periodically check for updates. When there is a software update available, an alert will appear when you start the Sonos 

Controller for Mac software. 
• Do not check for updates. 

1. From the Sonos menu, select Preferences.

2. Click Advanced.

3. On the General tab, select the Automatically check for updates checkbox if you want the Sonos system to check 
periodically for a newer version of the software.

Downloading software updates

When there is an update available,  Update Now appears in the MUSIC pane. 

1. Click  Update Now to begin the update process. 

You can also check for software updates by selecting Check for Updates from the Sonos menu.

http://faq.sonos.com/register
http://faq.sonos.com/register
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2. If there are updates available, click Next to download.

• Your Sonos products will all be updated as they must carry the same software version number. This process may take 
several minutes per device, depending upon your network connection. The Sonos Controller for Mac will automati-
cally close and then re-open during the update process.

Important Note:Do not disconnect power from your Sonos product(s), or in any way disable 
your Sonos system while this process is running. Contact Sonos Customer Support if an error 
occurs.

• Software updates to a handheld Sonos controller must be initiated from the controller, so if you have recently updated 
the Sonos Controller for Mac, you will be prompted to update your handheld controllers the next time you use them. 
Simply follow the on-screen prompts.

• If your software is up to date, the message “Your Sonos system is up to date. No Updates are Required.” will appear 
instead.

• One or more Sonos products may need to be updated when you purchase a new Sonos product with a later software 
version, or if you plug in a Sonos product that was not in use when you performed your last software update. If a prod-
uct’s software version gets out of sync with the rest of your Sonos system, a message will display in the ROOMS pane. 
Click the outdated room to begin the software update process.

For additional information, go to http://faq.sonos.com/updateerror.

Beta Programs
Sonos lets customers try out pre-release beta software to test new features and help us improve our products. While you are 
running beta software, usage data sharing is automatically turned on. 

1. From the Sonos menu, select Preferences -> Advanced.

2. On the Improve Sonos tab, click Beta Program, and then follow the on-screen prompts.

Uninstalling Sonos
If you wish to remove the Sonos Controller software from your Macintosh computer, choose Uninstall from the Sonos menu, 
and then drag the application to the trash. The Sonos system will no longer be able to access music from this computer.

Language Preference
The Sonos Controller will try to use the language you have selected in your OS X® operating system (System Preferences).

http://faq.sonos.com/updateerror
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Firewall Information
The Sonos Wireless HiFi System is designed to work with most firewall software. You will be prompted during setup to allow 
access to Sonos—be sure to allow access to Sonos when prompted or the Sonos system will not operate correctly. For the 
latest firewall information, go to http://faq.sonos.com/firewall.
You can also contact Sonos Technical Support at www.sonos.com/support.

Enabling Windows File Sharing
1. From the System Preferences window, select the Sharing folder.

2. Check the box next to File Sharing to turn file sharing on.

3. Click Options… and select Share files and folders using SMB (Windows).

4. Click Done.

http://www.sonos.com/support
http://faq.sonos.com/firewall


Managing Rooms
Sonos lets you enjoy music in up to 32 rooms, inside or out. You can play a different song in every room or play the same 
song in every room. Group the kitchen and patio together when you’re barbecuing; group the rooms throughout your home in 
perfect synchronization for a party; or leave all your rooms ungrouped so that everyone can make a different music choice.
Use the ROOMS list to: 

• Select a room to play music in
• See what’s playing in every room
• Group rooms together to play the same music in synchrony
• Remove a room from a room group

Grouping Rooms
Any number of rooms can be grouped together to play the same audio in synchrony. 

• You can group or ungroup rooms while music is playing. 
• You can group all the Sonos players in your house with one touch by choosing Select All. 
• You can group rooms first and then select the music you want to play, or you can add room(s) to a location where music 

is already playing. Any rooms you group will automatically drop their current music queue and begin to play the music 
from the selected room. 

• If you want to be able to play a music queue later, save the queue as a Sonos playlist before you group the rooms. See 
"Sonos Playlists" on page 5-15 for more information.
Chapter 4
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1. From the ROOMS pane, click Group to the right of the room you want to group with other rooms.

2. Check the rooms you want to add to this group, and then click Done. 

If you want to group all the rooms in your house, click Select All. All of your Sonos components will play the same music 
in synchrony until you remove rooms from the group.

Ungrouping Rooms
1. From the ROOMS pane, click Group to the right of the group you want to change. 

2. Uncheck the room(s) you want to remove from the group, and then click Done.



Music Sources

Available Music Sources
• Radio (Internet radio stations, radio shows, or podcasts)
• Music services
• iTunes music from an iPhone, iPad, or iPod touch that’s on the same network as your Sonos products
• Audio from an Android device that’s on the same network as your Sonos products
• Google Play Music (Android devices)
• Local music library (shared folders on your home network)
• Sonos Favorites
• Sonos playlists (music queues you have saved for future playback)
• Line-in (connect an external audio source like an Apple® AirPlay® device, CD player, TV, MP3 player or more to a Sonos 

product via line-in and stream the audio to any or all Sonos products around your house) 
• Music from UPnP servers
• Windows Media Player
• Docked iPods

What is radio?

Sonos includes a radio guide that provides immediate access to thousands of free Internet radio stations and broadcast 
programs. You can easily find Internet radio stations from all over the world—music, news, and variety programming, includ-
ing archived shows and podcasts. You can also add your own favorite stations if they use streaming MP3 or WMA formats 
(not every radio station provides streams).

What is a music service?

A music service is an online music store or online service that sells audio on a per-song, per audiobook, or subscription basis. 
Sonos is compatible with several music services - you can visit our Web site at www.sonos.com/music for the latest list. 

What is wireless iTunes playback from iOS devices?

Wireless iTunes playback allows you to select and play music and podcasts stored on any iPad, iPhone, or iPod touch that’s on 
the same network as your Sonos products. Once you make an audio selection from your iPad, iPhone, or iPod touch, you can 
use any Sonos controller to control playback. Playback is perfectly synchronized, in any or every room of your home. For 
more information, see the Sonos Controller for iPhone Product Guide or the Sonos Controller for iPad Product Guide.
Chapter 5
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What is wireless playback from Android devices?

Wireless playback from Android devices allows you to select and play music and podcasts stored on any Android device that’s 
on the same network as your Sonos products. Once you make an audio selection from your Android device, you can use any 
Sonos controller to control playback. Playback is perfectly synchronized, in any or every room of your home. 

What is Google Play Music service on Sonos?

You can play music to your Sonos system directly from the Google Play Music app on any Android device.

What is your local music library?

Your local music library includes digital music located anywhere on your home network, such as: 
• shared folders on your computer
• shared folders on another computer in your network
• Network-Attached Storage (NAS) devices

You can browse your music library in various ways. You can enter search criteria to quickly find a particular music selection, or 
you can browse through a category hierarchy to make music selections. 

Note: If a computer on your network is turned off or is in standby mode, the music folders on 
that computer will be unavailable to the Sonos system until the computer is turned back on. 

Your selection choices include:
• Artists
• Albums
• Composers
• Genres
• Tracks
• Imported playlists
• Folders
• Search

What is Sonos Favorites?

Sonos Favorites gives you quick and easy access to the music you love the most. You can add audio selections to your Sonos 
Favorites from any controller. Once you’ve added a favorite, it appears under Sonos Favorites on the MUSIC menu.

What is a Sonos playlist?

A Sonos playlist is a music queue you create and then save for future listening. For example, you might want to create a jazz 
playlist, a party playlist, or an easy listening playlist. 
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What is Line-in?

You can connect an external source like a CD player, portable music player, television, or AirPlay device to your Sonos system, 
and stream the audio to any or all Sonos products (PLAY:5, CONNECT™, or CONECT:AMP™) around your house. For information 
on connecting an external source, please see the Sonos® System Setup Guide.

What is music from UPnP servers?

Sonos can play music from compatible UPnP servers running on your network. If you are using a desktop application such as 
Rhapsody to organize the music on your local drive, your Sonos system can access the music server using Universal Plug and 
Play (UPnP).

What is Windows Media Player?

If you have Windows Media Player on your computer, you will need to turn on media sharing in Windows Media Player so that 
the Sonos system can access the music stored in your WMP library. When media sharing is turned on, Sonos can play all the 
music in your WMP library, including any DRM-free songs you’ve downloaded from a music service. 

What is a docked iPod?

The Sonos DOCK allows you to play music stored on your docked iPod or iPhone in any or every room of your home, all 
perfectly synchronized. 

Radio
Sonos includes a radio guide that provides access to thousands of free Internet radio stations and broadcast programs. You 
can easily find radio from all over the world—music, news, and variety programming, including archived shows and 
podcasts. 

• If you have a music service enabled on your computer, you can additionally select Internet radio stations from your 
music service. 

• Sonos currently supports MP3 and WMA streaming audio formats.
• If you can’t find your favorite radio station or show, go to http://faq.sonos.com/radio for additional information.

Selecting a local radio location 

Selecting a local radio location will give you easy access to local radio stations in that city. There are two ways you can set 
your location:

• by entering a ZIP code (U.S. only)
• by selecting a city

1. From the MUSIC pane, select Radio.

2. Select Local Radio, and then click Change Location.

3. Choose one of the following:

http://faq.sonos.com/radio
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• Enter ZIP Code, and then type a ZIP code.
• Pick a City, and then browse to find a location.

Adding a radio station 

You can use the Sonos Controller for Mac or PC to add a radio station that does not appear in the radio guide. You must know 
the streaming URL, and the station must use the streaming MP3 broadcast format. This station will be added to your Favor-
ites list. 

1. From the Manage menu, select Add Radio Station.

2. Type the streaming URL for the radio station you want to add to your station list (for example: 
http://shoutcast.com/sbin/shoutcast-playlists.pls?rn=8107&file=filename.pls). 

3. Type the radio station’s name in the Station Name field, and then click OK.

The new radio station appears in your My Radio Stations list.

Editing a radio station 

Use the Sonos Controller for Mac or PC to edit a radio station.

Note: You can only edit the streaming URL or station name for those radio stations you 
manually added to your My Radio Stations list. 

1. From the MUSIC pane, select Radio. 

2. Browse to find the station you want to edit.

3. Click  next to the radio station you want to edit, and then choose Edit Radio Station

4. Change the streaming URL or the station name, and then click OK.

Adding a station or show to My Radio 

When you add a radio station to My Radio Stations (or a show to My Radio Shows), it is duplicated, not removed, from the 
original radio list. 

1. From the MUSIC pane, select Radio. 

2. Find the station or show you want to add to your list.

3. Click  next to the radio station or show, and then choose Info & Options. 

4. Click Add to My Radio Stations or Add to My Radio Shows.

You can also add a station or show while listening to it by clicking , and then clicking Add to My Radio Stations or Add 
to My Radio Shows. 

Removing a station or show from My Radio

1. From the MUSIC pane, select Radio. 

2. Click My Radio Stations or My Radio Shows and find the station or show you want to remove.
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3. Click  next to the selection, and then choose Info & Options. 

4. Click Remove from My Radio Stations or Remove from My Radio Shows.

Music Services
A music service is an online music store or online service that sells audio on a per-song, per audiobook, or subscription basis. 
Sonos is compatible with several music services—to view the latest list, visit our Web site at www.sonos.com/music. For 
information about using a specific music service, go to http://faq.sonos.com/musicservices. 
You can associate up to 32 music service accounts with your Sonos system. Each Sonos controller can have a unique music 
service account associated with it so that everyone gets their own custom music experience. For example, you can use your 
Pandora account (with your radio stations and preferences) and your son can use his Pandora account (with his radio 
stations and preferences). 
When you add a music service account to a Sonos controller, it becomes the default account for that controller. You can 
switch between accounts by changing the default account for a controller at any time. See "Changing the default music 
service account" on page 5-8 for more information. Pandora features, such as the ability to like tracks, are only available on 
the controller that started the playback so if you start playing a Pandora station on your controller, you are the only one who 
can like tracks. For all other services, the options that are available depend on the permissions of the default music service 
account. For example, if the default Spotify account on a Sonos controller is the trial version of the service, only certain 
options will be available. For more information, go to http://faq.sonos.com/multiaccount.

Note: You can build playlists from multiple music service accounts, but you will not have the 
ability to see which account the tracks came from.

 

• Some music services may not be available in your country. Please check the music service’s Web site for more informa-
tion.

• To activate any of the free music service trials that are included with your Sonos system, your Sonos system must be 
registered. If you have not yet registered, go to http://faq.sonos.com/register for help with this step.

• The MUSIC menu displays the music services that are set up to work with Sonos.
• To add or update a music service, click Add Music Services from the MUSIC menu.

Activating a music trial

Free music service trials are available in some countries. (Please check the individual music service’s Web site for more infor-
mation.) If there is a music service trial available on your controller, simply follow the steps below to activate it. After the trial 
period is up, you will need to subscribe to the music service to keep the music playing.

1. From the Manage menu, select Service Settings.

The music services that are currently configured to work with your Sonos system are displayed. 

2. Click Add (PC) or  (Mac).

3. Select the music trial you would like to activate, and then click Next. 

4. Specify that you are new to the service, and then click Next.

5. Click the link to go to the website for the music service and set up an account there.

http://www.sonos.com/music
http://faq.sonos.com/musicservices
http://faq.sonos.com/register
http://faq.sonos.com/register
http://faq.sonos.com/multiaccount
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6. After you have set up a music service account, click Next

You will be asked to provide a nickname for your account. If there are multiple accounts for this music service associated 
with your Sonos system, the nickname appears below the music service name on the music menu so you always know 
which account you are using. You can change the account nickname or switch to a different account at any time. See 
"Changing the music service account nickname" on page 5-7 and "Changing the default music service account" on 
page 5-8 for more information.

After the trial expires

If you want to subscribe to a music service after your free trial expires, go to the music service’s website to sign up. Once you 
become a subscriber, simply update Sonos with your membership information (steps below) and you’ll have instant access 
to the music service from your Sonos system.

1. From the Manage menu, select Service Settings.

2. Choose one of the following:

• Using the Sonos Controller for PC, select the music service you wish to subscribe to, and click Subscribe.
• Using the Sonos Controller for Mac, click Subscribe next to the service you wish to subscribe to.

3. Click the link to go to the website for the music service and set up an account there.

4. After you have subscribed to the music service, click Next.

5. Enter your music service login and password, and click Next.

After your login and password have been verified by the music service, you can select your music service in the MUSIC 
pane, and make a music selection.

Note: If your music service does not appear in the MUSIC pane, your firewall may be 
preventing Sonos from accessing it. For additional information, go to 
http://faq.sonos.com/firewall.

Adding a compatible music service account

If you are currently subscribed to a music service that’s compatible with Sonos, simply add your music service login and 
password information (as needed) to Sonos and you’ll have instant access to the music service from your Sonos system. To 
see the latest list of compatible music services, go to www.sonos.com/music.
You can associate up to 32 music service accounts with your Sonos system, including multiple accounts for the same music 
service—each Sonos controller can have a different default music service account so that everyone gets their own custom 
music experience. 
(If you have not yet subscribed to a music service, first go to the music service’s Web site to sign up. Once you become a 
subscriber, simply follow the steps below to add your account information to Sonos.) 

1. From the Manage menu, select Service Settings.

The music services that are currently configured to work with your Sonos system are displayed. 

2. Click Add (PC) or  (Mac).

3. Select the Sonos-compatible music service you would like to add, and then click Next.

http://www.sonos.com/music
http://faq.sonos.com/firewall
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4. Select I already have an account, and then click Next.

5. Enter your music service login and password, and click Next.

Note: If you’re a Spotify user, you can choose to log in with your Spotify account information 
or your Facebook credentials.

 

You will be asked to provide a nickname for your account. If there are multiple accounts for this music service associated 
with your Sonos system, the nickname appears below the music service name on the music menu so you always know 
which account you are using. You can change the account nickname or switch to a different account at any time. See 
"Changing the music service account nickname" on page 5-7 and "Changing the default music service account" on 
page 5-8 for more information.
Your login and password will be verified with the music service. Once your credentials have been verified, you’ll have 
instant access to the music service—it will appear as an option on the MUSIC menu.

Note: If your music service does not appear in the MUSIC pane, your firewall may be 
preventing Sonos from accessing it. For additional information, go to 
http://faq.sonos.com/firewall.

Changing your music service password

If you want to change the password for a music service you subscribe to, such as Spotify, Rhapsody, or SiriusXM, you must 
first change the password with your music service provider by going to their website and changing your password in the 
account settings. Once you've changed your password there, update your Sonos system:

1. Go to your music service provider’s Web site, and change your password in the account settings. 

After you've changed your password there, follow the steps below to update your Sonos system.
2. From the Manage menu, select Service Settings.

3. Highlight the music service you wish to update.

4. Choose one of the following:

• On a PC, click Edit.
• On a Mac, click , and then select Change Password.

Note: If you don’t change your password with the music service first, it won’t work on your 
Sonos system.

Changing the music service account nickname

The account nickname appears below the music service name in the music menu.

1. From the Manage menu, select Service Settings.

2. Highlight the music service account you wish to update.

3. Choose one of the following:

• On a PC, click Edit.

http://faq.sonos.com/firewall
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• On a Mac, click , and then select Change Nickname.

Changing the default music service account

You can quickly and easily change the default music service account for a controller.

1. Click  next to a music service in the MUSIC pane.

2. Select a different account.

The nickname for the default account for the controller appears below the music service name in the music menu. 

Caution: Any changes you make, such as liking tracks, affect the preferences for the 
default music service account.

Replacing a music service account 

1. From the Manage menu, select Service Settings.

2. Select the music service you wish to replace.

3. Choose one of the following:

• On a PC, click Replace. 
• On a Mac, click , and then select Replace Account.

4. Enter your music service login and password, and then click Next.

After your login and password have been verified by the music service, you can select the music service from the MUSIC 
pane, and make a music selection.

Reauthorizing a music service account

Periodically, you may be asked to reauthorize account with a music service.

1. From the Manage menu, select Service Settings.

2. Select the music service that has the account you wish to reauthorize.

3. Choose one of the following:

• On a PC, click Reauthorize, and then follow the on-screen prompts. 
• On a Mac, click , select Reauthorize, and then follow the on-screen prompts.

Removing a music service account from Sonos 

You may wish to remove a music service account from your Sonos system—for example, you might want to remove a music 
service trial after it has expired.

1. From the Manage menu, select Service Settings.

2. Select the music service account you wish to remove, and click Remove (PC) or  (Mac). 

Note: All controllers that used this account as the default account now use the oldest 
account associated with your Sonos system as the default account.
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This will not delete your account from the music service—your account status with the music service will be unaffected.

Removing a music service trial

When a music service trial expires, you may wish to remove the expired trial from your Sonos system.

1. From the Manage menu, select Service Settings.

2. Select the trial music service you wish to remove.

3. Click Remove (PC) or  (Mac), and then follow the on-screen prompts. 

Note: All controllers that used this account as the default account now use the oldest 
account associated with your Sonos system as the default account.

Sonos Labs

Be among the first to try out a new music service before it is officially released! When you see a music service listed in Sonos 
Labs, you can go to that music service’s website, create an account, and then add your account information to Sonos. 
Sonos continually updates the list of available beta music services, so please check back frequently.

1. From the Manage menu, select Service Settings.

2. Click Sonos Labs (PC) or Visit Sonos Labs (Mac).

3. Select the service you would like to add, and then click Next.

You will be asked if you want to share usage data, if you have not done so already.
4. Select I already have an account, and then click Next.

5. Enter your music service login and password, and then click Next.

After your login and password have been verified by the music service, you can select the music service from the MUSIC 
pane, and make a music selection.

Note: If your music service does not appear in the MUSIC pane, your firewall may be 
preventing Sonos from accessing it. For additional information, go to
http://faq.sonos.com/firewall.

Wireless iTunes Playback from iOS Devices
You can select and play music and podcasts stored on any iPad, iPhone, or iPod touch that’s on the same network as your 
Sonos products. Playback is perfectly synchronized, in any or every room of your home. Simply choose This iPad, This 
iPhone, or This iPod touch from the Sonos app on your iOS device to make audio selections and then you can use any Sonos 
controller to control playback.
Wireless playback requires Sonos Controller App for iPhone or iPad version 3.8.3 or higher and devices running iOS software 
version 6.0 or later.

http://faq.sonos.com/firewall
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Wireless Playback from Android Devices
You can select and play music stored on any Android device that’s on the same network as your Sonos products. Playback is 
perfectly synchronized, in any or every room of your home. Simply choose This Mobile Device from the Sonos app on your 
Android smartphone or tablet to make audio selections and then you can use any Sonos controller to control playback.
Wireless music playback is compatible with Sonos software update 4.1.1 and higher, and any device running Android 2.1 and 
higher. (Wireless playback of podcasts is supported on Android 2.2 and higher.) 

Google Play Music (Android Devices)
You can play music to your Sonos system directly from the Google Play Music app on any Android device. This feature is avail-
able for both Standard and All Access Google Play Music customers. 
To play music directly from the Google Play Music app to your Sonos system, you must have both the Google Play Music app 
and the Sonos Controller app installed on your mobile device. Sonos playback from Google Play Music is compatible with 
Sonos software update 4.3 and higher, and with any device running Android 2.3 and higher.
Simply open the Google Play Music app and connect to a Sonos room or room group to start the music. When you are 
finished, disconnect the Sonos room from the app.

Managing Your Local Music Library
The Sonos system can play music from any computer or Network-Attached Storage (NAS) device on your home network 
where you have shared music folders. During the setup process, you are guided through the process of accessing your local 
music library (such as your iTunes library). Over time, you may wish to add or remove music folders from this list.
Once you’ve set up your local music library, you can play selections from it by choosing Music Library from the Music menu.

Note: If you have uncompressed WAV or AIFF files in your music collection, they may only be 
available for browsing and/or selection via Tracks or Folders as uncompressed files may not 
contain detailed information such as artist, title and genre.

Adding a shared folder

To make another shared folder available to your Sonos system:

1. From the Manage menu, select Music Library Settings.

The shared music folders that are currently available to your Sonos system appear. 

2. Select the Folders tab and click Add (PC) or  (Mac).

3. Choose one of the following options:

• In my Music folder, and then click Next. Follow the on-screen instructions to make your music accessible to the Sonos 
system. If necessary, you will be guided through the steps for sharing the music folder and adjusting your computer’s 
sleep settings. 
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• In another location on my computer, or on an external drive connected to my computer, and then click Next. Type 
the path or browse to the location where your music is stored and follow the on-screen instructions to make your music 
accessible to the Sonos system. If necessary, you will be guided through the steps for sharing the music folder and 
adjusting your computer’s sleep settings.

• On a networked device such as a network attached storage (NAS) drive, and then click Next.
a. Type the network path for the music folder (\\Name\Sharename, where Name is the network name for your computer 

or NAS device, and Sharename is the name of the top level shared folder), or click Browse (PC) to navigate to it. Click 
Next.

b. If it is not shared anonymously, enter the user name and password of a user with permission to access this folder, and 
then click Next.

• Add audio books from my Audible folder (PC), and then click Next. Follow the on-screen instructions to make your 
audio books accessible to the Sonos system. If necessary, you will be guided through the steps for sharing the folder 
and adjusting your computer’s sleep settings.

Windows Sharing on a Mac 

Depending upon where your music is stored, you may be asked to provide an administrator name and password to allow 
access to your music folders. 
If your Macintosh computer does not have Windows Sharing enabled, the Sonos Controller for Mac or PC will guide you 
through the process of enabling it. Your music files are never copied from their current locations - your folders are simply 
shared so they can be accessed by your Sonos system.

Viewing shared folders

• From the Manage menu, select Music Library Settings.
The shared music folders that are currently accessible to your Sonos system are displayed. (If a computer on your network is 
turned off or is in sleep or standby mode, the music on that computer will be unavailable to the Sonos system until the 
computer is turned back on.)

Stop accessing a shared folder

1. From the Manage menu, select Music Library Settings.

2. Click the Folders tab.

3. Select the shared folder you want to remove from the list, and then click Remove (PC) or  (Mac). 

4. Confirm that you want to delete the shared folder.

Updating the music index 

The Sonos system indexes your local music library so you can view your music collection by categories (such as artists, 
albums, composers, genres, or tracks.) During setup, all of your available music folders are indexed for easy selection. If you 
add new music, simply update your music index to add this music to your local music library. 

1. From the Manage menu, select Update Music Library Now.



Product Guide5-12
2. Click Yes to confirm.

The message, “Indexing” appears in the MUSIC pane. When the update is complete, the message disappears. 

Scheduling automatic updates 

You can set your music system to automatically update your music index at the same time each day. 

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab.

3. Check the Update content every day at box, and then select the time of day you would like your music index to 
automatically update.

Contributing artists

Contributing Artists are those who appear on individual tracks within an album, including those on a compilation or 
soundtrack album. You can set your preferences to show or hide these individual artists within a Contributing Artists view.

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab.

3. Check or uncheck the Show Contributing Artists checkbox. 

If this box is not checked, the Contributing Artists view will not display.
The Show Contributing Artists preference setting you select applies only to this Sonos Controller for Mac or PC. If you have 
another Sonos controller, you can select a different Contributing Artist view for it. 

Imported playlists (M3U, WPL and PLS support)

The Sonos system is compatible with iTunes playlists as well as M3U, WPL and PLS playlist files created with third-party soft-
ware (for example, iTunes, WinAmp, Windows Media Player, and so on). The Sonos system does not change music or playlist 
files created by other applications; these files are always treated as “read-only.”
To play music from imported playlists, drop the playlist file .PLS, .M3U or .WPL into the same music folder you have shared to 
the Sonos system, update your music index, and the custom playlists will appear when you select Imported Playlists from 
the Music Library menu.

iTunes support

You can view your iTunes playlists in the Sonos system by selecting Imported Playlists from the Music Library. 
When you make changes to your iTunes playlist(s), exit iTunes, and then update your Sonos music index to see the changes 
(see "Updating the music index" on page 5-11.)
iTunes playlists are automatically imported into the Imported Playlists menu as long as your 'iTunes Music Library.xml' file is 
shared along with your music to the Sonos system. For typical iTunes installations, this file is located in the iTunes folder.
Sonos is unable to play tracks that are protected by Apple’s proprietary Digital Rights Management (DRM) scheme. 
For additional information, go to http://faq.sonos.com/iTunes.

http://faq.sonos.com/iTunes
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Sort folders by preference

You can set the sorting preference for music folders that are accessible from your local music library. You can choose to sort 
by:

• Track name
• Track number
• File name

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab and select your sort order preference from the drop-down Sort Folders by list.

Compilation albums

If your music collection contains compilations and soundtracks, you may want to group these songs together in your music 
library instead of viewing them by individual artist. This means that any artists that appear solely on compilations will not 
appear in your Artists list. You can choose to group compilations within Sonos by:

• iTunes compilations
• Album artist

Group using iTunes compilations
iTunes normally organizes your iTunes Music folder as [Artist]/[Album]/[Track name]. iTunes has a feature that allows you to 
group your compilations albums together. This will organize your compilations and soundtrack albums as [Compilations]/
[Album]/[Track name]. 
Within iTunes:

1. Mark individual tracks as being part of compilations by highlighting the track and then selecting File -> Get Info. 

2. Check the Part of a compilation checkbox. 

3. Select View -> Column Browser and select the Group Compilations option. This will group the tracks you’ve marked as 
compilations.

Within Sonos:
You can organize your local music library to use this iTunes compilation view.

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab and select iTunes compilations from the Group Albums using drop-down list.

The music library updates immediately when you select this option.
3. If you would like to see the individual artists displayed in a Contributing Artist view, check the Show Contributing Artists 

checkbox. 

If this box is not checked, the Contributing Artists view will not display.
The Show Contributing Artists preference setting you select applies only to this Sonos Controller for Mac or PC. If you have 
another Sonos controller, you can select a different Contributing Artist view for it. 
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Group using AlbumArtists
Windows Media Player, as well as some other players, use the Album Artist category to group compilations and sound track 
albums (the Album Artist is the person, group or composer the album would be filed under in a store).
You can organize your local music library to use the AlbumArtist compilation view.

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab and select Album Artists from the Group Albums using drop-down list.

3. If you would like to see the individual artists displayed in a Contributing Artist view, check the Show Contributing Artists 
checkbox. 

If this box is not checked, the Contributing Artists view will not display.
The Show Contributing Artists preference setting you select applies only to this Sonos Controller for Mac or PC. If you have 
another Sonos controller, you can select a different Contributing Artist view for it. 

Do not group compilations
If you choose not to group compilation albums, the individual artists will display within your Artists view. 

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab and select Do not group compilations from the Group Albums using drop-down list. 

All of the individual artists will then appear in the Artists view.

Resetting local music library permissions on a PC 

Some music services may automatically change the permissions on your music folders when you add music, so that Sonos 
can no longer access your music. If your music service does this, you can change the preference setting to allow Sonos to 
reset permissions when your music index is updated. You should not set this preference unless you need to, as it takes longer 
to update your music index when this box is checked.

1. From the Manage menu, select Music Library Settings.

2. Click the Advanced tab.

3. Check the Fix permissions on music files so that Sonos can always access them box.

Sonos Favorites
Sonos Favorites gives you quick and easy access to the music you love the most. You can add audio selections to your Sonos 
Favorites from any controller. Once you create a Favorite, it appears under Sonos Favorites on the MUSIC menu.

Note: Audio from docked iPods, wireless playback from iOS and Android devices, and line-in 
sources cannot be added to Sonos Favorites since these music sources may not always be 
available to your Sonos system.
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Creating a Sonos Favorite

1. From the MUSIC menu, browse to find the selection you want to add to your Sonos Favorites. 

2. Click  to the right of the selection, and choose Add to Sonos Favorites.

If there are multiple accounts for the music service associated with your Sonos system, the nickname for the music 
service account used to create the favorite appears below the selection in the Sonos Favorites list.

Note: To create a favorite from the selection you are currently listening to, click  from 
the NOW PLAYING pane and choose Add to Sonos Favorites.

 

Deleting a Sonos Favorite

1. Select Sonos Favorites from the MUSIC menu.

2. Click  to the right of the selection you wish to delete, and choose Delete Favorite.

Renaming a Sonos Favorite

1. Select Sonos Favorites from the MUSIC menu.

2. Click  to the right of the selection you wish to rename, and choose Rename Favorite.

Note: When you rename a Sonos Favorite playlist, the playlist name remains unchanged if 
you access it through the Sonos Playlists menu option.

Sonos Playlists 
Sonos playlists are music queues you create and save for future listening. For example, you might want to create a jazz play-
list, a party playlist, or an easy listening playlist. 

Note: You can build playlists from multiple music service accounts, but you will not have the 
ability to see which account the tracks came from.

Creating a Sonos playlist

While browsing music, you can create a Sonos playlist or add to an existing playlist. Simply click  to the right of a selec-
tion and choose Add to Sonos Playlist. Click New Playlist or select an existing playlist.
You can also save a music queue as a Sonos playlist by choosing Save Queue from the QUEUE pane. 

Note: Tracks that reside on your iPhone, iPod touch, or iPad, or on your Android device are 
not included in a Sonos playlist. For more information, see "Wireless iTunes Playback from iOS 
Devices" on page 5-9 and "Wireless Playback from Android Devices" on page 5-10.
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Adding to an existing Sonos playlist

Note: Tracks that reside on your iPhone, iPod touch, iPad, or on your Android device are not 
included in a Sonos playlist. For more information, see "Wireless iTunes Playback from iOS 
Devices" on page 5-9 or "Wireless Playback from Android Devices" on page 5-10.

1. Select a music source from the MUSIC pane.

2. Browse to find a track or album.

3. Click  next to the track or album you want to add to an existing Sonos playlist, and then select Add to Sonos Playlist.

Note: The options that appear depend on the music source you have selected.

 

4. Select an existing playlist name to add the selection.

Note: While listening to a track, you can add it to a playlist. Simply click  from the NOW 
PLAYING pane, and then select Add Track to Sonos Playlist. While viewing the queue, you 
can save it as a playlist by choosing Save Queue.

Moving a track within a playlist

1. Select Sonos Playlists in the MUSIC pane.

2. Select a playlist.

3. Choose one of the following:

• To move a single track, click the track you want to move and drag it to a new location within the playlist. Once it is in 
the desired location, release the mouse button.

• To move multiple tracks, check the box to the right of each track you want to move. Click and drag the tracks to a new 
location within the playlist, and then release the mouse button.

You can select tracks that are not next to each other in the playlist. They maintain their current order in the new location.
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Deleting a track from a playlist

1. Select Sonos Playlists in the MUSIC pane.

2. Select a playlist.

3. Choose one of the following:

• To remove a single track, click  next to the track you want to remove from the playlist, and then select Remove 
Track.

• To remove multiple tracks, check the box to the right of each track you want to remove from the playlist, click  next 
to one of the selected tracks, and then select Remove Tracks.

Deleting a Sonos playlist

1. Select Sonos Playlists in the MUSIC pane.

2. Click  next to the playlist you want to delete, and select Delete Playlist. 

Note: If you delete a playlist that is also a Sonos Favorite, see "Deleting a Sonos Favorite" on 
page 5-15 to remove it from your Sonos Favorites.

Replacing the tracks in a playlist

You can replace the tracks in a playlist with the contents of the queue by choosing Save Queue, and then selecting an 
existing playlist.

Note: Tracks that reside on your iPhone, iPod touch, iPad, or on your Android device are not 
included in a Sonos playlist. For more information, see "Wireless iTunes Playback from iOS 
Devices" on page 5-9.
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Renaming a Sonos playlist

1. Select Sonos Playlists in the MUSIC pane.

2. Click  next to the playlist you want to rename, and select Rename Playlist. 

Note:  If you rename a Sonos playlist that is also a Sonos Favorite, the playlist name remains 
unchanged when you access it through the Sonos Favorites menu option. 

Music from UPnP servers
Sonos can play music from compatible UPnP servers running on your network. If you are using a desktop application such as 
Rhapsody to organize the music on your local drive, your Sonos system can access the music server using Universal Plug and 
Play (UPnP). You should only use this method to access the music service’s server if you are using their desktop application 
to access music or if you have multiple accounts for the same music service active in your household. 
To access a music server using UPnP, first make sure UPnP is enabled in the music service desktop application so that the 
Sonos system can recognize it and show the music service in your music library. This is a one-time preference setting. 
Remember—your computer must be on in order to stream content if you are accessing a music server this way.
After you have enabled UPnP in the music service’s desktop application, simply adjust the settings on your Sonos system to 
allow the music servers to display. See "Displaying music servers on Sonos" on page 5-19 for more information.

Windows Media Player
If you have Windows Media Player on your computer, you will need to turn on media sharing in Windows Media Player so that 
the Sonos system can access the music stored in your WMP library. When media sharing is turned on, Sonos can play all the 
music in your WMP library, including any DRM-free songs you’ve downloaded from a music service. 
For additional information, go to http://faq.sonos.com/wmpsharing. 

Enabling Windows media sharing

1. Start Windows Media Player.

2. Click Stream.

3. Choose one of the following options:

• Allow Internet access to home media
• Allow remote control of my player
• Automatically allow devices to play my media—you may want to choose this option so streaming will automatically 

be allowed each time you add a device to your network.

http://faq.sonos.com/wmpsharing
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When you turn on media streaming, you can select More streaming options to see a list of your networked devices. You can 
choose to allow or block individual devices.

Note: If you do not allow media streaming on all Sonos products, those Sonos products will 
not be able to play the music stored in your Windows Media Player library.

After you have turned on media sharing in Windows Media Player, simply adjust the settings on your Sonos system to allow 
the music servers to display. See "Displaying music servers on Sonos" on page 5-19 for more information.

Displaying music servers on Sonos

1. Choose one of the following:

• Using the Sonos Controller for PC, select Manage -> Settings.
• Using the Sonos Controller for Mac, select Sonos -> Preferences.

2. Select Advanced.

3. On the Music Servers tab, choose one of the following options under Local Music Servers:

• Check the Show Windows Media Servers checkbox. 
• Check the Show Rhapsody UPnP servers checkbox. 

Docked iPods
You can select music directly from your device when it is seated in the DOCK (autoplay mode), or you can use any Sonos 
controller to make music selections and control playback (accessory mode). Place a compatible device in the DOCK, and 
select Docked iPods from the Music menu. 
The DOCK is compatible with:

• iPod touch (1st, 2nd, 3rd, and 4th generation)
• iPod classic
• iPod nano (3rd, 4th, 5th and 6th generation)
• iPhone 4, 4S, iPhone 3GS
• iPhone 3G, iPhone



Playing Music
You can select music by selecting a music source from the MUSIC pane, select a category (such as Artists, Albums, or 
Composers), and then drilling down through the selected source, or you can search for music in a specific source.

Selecting Music
Browse

1. From the ROOMS pane, click to highlight the room you want to play music in.

2. Select a music source from the MUSIC pane.

3. Select a category, such as Artists, Albums, or Composers, and click to drill down through the category until you reach 
the choice you want.

4. Click  to the right of the selection, and then choose one of the following options:

• Play Now to start playing the selection. If the selection has tracks, they are added to the end of the queue.
• Play Next to add the selection to the music queue as the next selection to play.
• Add to Queue to add the selection to the end of your music queue.
• Replace Queue to remove the contents of the current queue, replace it with this selection, and start playing it the first 

track of the selection. 
• Add to Sonos Favorites to add the selection to your list of favorites.
• Add to Sonos Playlist to add the selection to an existing playlist or create a playlist that has this selection. iTunes 

tracks that reside on your iPhone, iPod touch, or iPad are not included in a Sonos playlist. For more information, see 
"Wireless iTunes Playback from iOS Devices" on page 5-9. 

• Info & Options to display additional options, such as adding a track to your Sonos favorites or viewing artist/album 
information. 

Note: The options that appear depend on the music source you have selected.

 

If you’ve created Sonos playlists (saved queues), you can play them anytime by selecting Sonos Playlists from the MUSIC 
pane. 

Note: The music you select will play in the room or group that’s highlighted in the ROOMS 
pane. 
Chapter 6
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Multi-Select

1. Check the box that appears on the right for each item you want to select.

2. Choose one of the following:

• Click  to choose an option.

• Play Selected Now to add the selection to the end of the queue and start playing the first track of the selection.
• Play Selected Next to add the selection to the music queue as the next selection to play.
• Add Selected to Queue to add the selection to the end of your music queue.
• Replace Queue to remove the contents of the current queue, replace it with this selection, and start playing the 

first track of the selection.
• Drag and drop the selections to the QUEUE pane or the ROOMS pane.

Note: You can also double-click a selection to add it to the end of the queue and start 
playing the first track of the selection.

 

Drag and Drop

You can drag and drop selections directly from a music source to the queue or to a room. Click a selection and, while holding 
down the mouse, drag the selection to the QUEUE or ROOMS pane, and then release.
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Searching for Music

1. From the ROOMS pane, select the room you want to play music in.

2. Choose one of the following:

• From the MUSIC pane, select the source you want to search.
• Click the down-arrow in the Search box and select the source you want to search. (For Pandora, the box says New 

Station.)
3. Enter your search criteria (full or partial). As you type, the list populates.

You can also search using the metadata for a track by highlighting the track, and then selecting Edit -> Copy. You can 
then paste this content into the Search box in your Sonos Controller for Mac or PC. You can also paste this content into an 
online search engine.

4. Click a category you wish to search (for example, Artists, Albums, Composers, or Tracks).

Mini Controller
The Mini Controller includes playback controls plus access to information about the track that is currently playing. 

1. Choose one of the following:

• Select File -> Show Mini Controller (PC).
• Select Window -> Mini Controller (Mac).
• From the NOW PLAYING pane, click the album art.
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2. Mouse over the large album art to display the playback controls.

3. Choose one of the following:

• Click the playback controls to play, pause, or mute your music. Playback controls are also available by mousing over 
the Sonos Controller icon in the system tray (PC) or right-clicking the Sonos Controller icon in the dock (Mac).

• Click  to display options for viewing artist/album information or adding a track/album to your music library. The 
information appears in the MUSIC pane.

• Click  (Windows) or  (Mac) to resize the Mini Controller. Click again to return the Mini Controller to its previous 
size. 

• Close the Mini Controller.

Note: You can also click the large album art in the Sonos Controller for Mac or PC main 
display to close the Mini Controller.

Managing the Music Queue
When you select tracks, they are added to a list called a music queue. You can create a different queue for each room in your 
home, or you can group rooms together to play the same audio. Tracks in the queue will play in order unless you turn on 
shuffle and/or repeat. 
Once you have added tracks to a queue, you can make changes to the music queue using the queue controls. Sonos playlists 
are music queues you create and save for future listening. For more information, see "Sonos Playlists" on page 5-15.

Note: Wireless playback from iOS and Android devices allows you to select and play music 
and podcasts stored on any iPhone, iPad, iPod touch, or Android device that’s on the same 
network as your Sonos products. If there are tracks in the queue from a mobile device that is 
not currently available to Sonos, you may see a message indicating that the selection cannot 
be played at this time.
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Playing a track from the queue

Click  next to a track in the QUEUE pane, and then select Play Track. Playback continues through the tracks in the 
queue.

Deleting a track from the queue

Choose one of the following:
• To remove a single track, in the QUEUE pane, click  next to the track you want to remove from the music queue, 

and then select Remove Track.
• To remove multiple tracks, in the QUEUE pane, check the box to the right of each track you want to remove from the 

queue. Click  next to one of the selected tracks, and then select Remove Selected Tracks (PC) or Remove Tracks 
(Mac).
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Moving a track within the queue

Choose one of the following:
• To move a single track, in the QUEUE pane, click the track you want to move and drag it to a new location within the 

queue. Once it is in the desired location, release the mouse button.
• To move multiple tracks, in the QUEUE pane, check the box to the right of each track you want to move. You can select 

songs that are not next to each other in the queue. Drag the tracks to a new location within the queue, and then release 
the mouse button.

When you select tracks, they will maintain their current order in the new location.

Clearing the queue

• Click Clear Queue from the bottom of the QUEUE pane.
This clears the entire queue in the selected room and the music stops playing.

Saving a queue as a Sonos playlist

• Click Save Queue from the QUEUE pane.
You can access these playlists anytime by selecting Sonos Playlists from the Music menu.

Note: Tracks that reside on your iPhone, iPod touch, iPad or your Android device are not 
included in a Sonos playlist.
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Resizing the QUEUE pane

Choose one of the following:
• Click  to expand the size of the QUEUE pane and display more of the list of tracks queued to play. The NOW 

PLAYING pane slides out of view.

• Click  to make the QUEUE pane smaller. The NOW PLAYING pane displays.
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Changing the play mode

• Click the Repeat, Shuffle, or Crossfade buttons to change the play mode. 
The icon for the selected play mode appears highlighted.

Shuffle Plays the tracks in the music queue in a 
random order.

Repeat Repeats the music queue after the last track 
has finished.

Crossfade Fades out the current track while fading in 
the next track to create a smooth transition 
between tracks.

Turning Off the Music System
Your Sonos system is designed to be always on; the system uses minimal electricity whenever it is not playing music. 

• To quickly stop streaming audio in all rooms, select Pause All from the ROOMS pane.
• To quickly stop streaming audio in a room or room group, press the Play/Pause button on a Sonos player (may appear 

as a Mute icon on some players). 

Your Sonos products remain off until you select  on a Sonos Controller app, or press the Play/Pause button on a player 
to restart each room or room group. 



Tips and Troubleshooting
Basic Troubleshooting
Warning: Do not open Sonos products as there is a risk of electric shock. Under no 
circumstances should Sonos products be repaired by anyone other than an authorized Sonos 
repair center, as this will invalidate the warranty. Please contact Sonos Customer Support for 
more information. 

If a problem occurs, you can try the troubleshooting suggestions listed below. If one of these doesn’t remedy the problem, or 
you are not sure how to proceed, please contact the Sonos Customer Support team and we’ll be happy to help.

Sonos product(s) not detected during setup

• Check to make sure the power cord is properly seated.
• A network issue may be preventing the product from connecting to your Sonos system. If this is a wireless Sonos 

product, try moving the Sonos components closer together, or use an Ethernet cable to hard wire the product to your 
router temporarily to see if the problem is related to wireless interference. 

If you encounter this message while a Sonos product is connected to your router, you can try the steps below to resolve this 
issue. If you are still experiencing problems, please contact Sonos Customer Support.

1. Check the firewall

Firewall software installed on the computer may be blocking the ports that Sonos uses to operate. First, disable all your 
firewalls and try to connect again. If this resolves the problem, you should configure your firewall to work with the Sonos 
Controller for Mac or PC. Please go to our Web site at http://faq.sonos.com/firewall for additional information. If this does not 
resolve the problem, you can try step 2 below.
A

http://faq.sonos.com/firewall
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2. Check the router

You can bypass your router’s switch to determine whether there are any router configuration issues by connecting a Sonos 
product as shown below—in this BOOST configuration example, note that the BOOST and the computer still have Internet 
access:

• Be sure that your cable/DSL modem is connected to the router’s WAN (Internet) port. 
• Temporarily remove any other components that are wired to your network. 
• Connect an Ethernet cable from the computer directly to the back of the BOOST, and then connect another Ethernet 

cable from that Sonos product directly to one of the LAN ports on your router. 
• When you make a change to your network configuration, you may need to power cycle the Sonos product by 

unplugging the power cord, and then plugging it back in.
• If you are not using a router, you can visit our Web site at http://faq.sonos.com/norouter for more information.

3. Check the wiring

Check the indicator lights on both the router and the Sonos product. The link/status lights should be lit solid, and the activity 
lights on the router should be blinking. 

• If the link lights are not lit, try connecting to a different port on your router. 
• If the link lights still do not light, try connecting a different Ethernet cable.

Sonos player is not operating properly

• If the status indicator is not lit and no sound is produced when the unit is plugged in, check to ensure the power cord 
is properly seated.

• If the status indicator is solid white, make sure the volume is set to a suitable level; make sure MUTE is not on; if 
CONNECT:AMP, make sure external speakers are connected securely.

• If the player has suddenly stopped playing music and the status indicator is flashing orange and white, pause or unplug 
the player for a few minutes to allow it to cool. Check to make sure the vents are not blocked. See "Player Status 
Indicators" on page A-5.

• Check the link/activity lights on both the router and the Sonos product that is wired to your router.The link lights should 
be lit solid and the activity lights should be blinking. 

http://faq.sonos.com/norouter
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• If the link lights are not lit, try connecting to a different port on your router. 
• If the link lights still do not light, try using a different Ethernet cable.

• Move your Sonos controller closer to a player.
• Check to ensure there are no obstacles to impede wireless operation.
• Check your network connections.
• The Sonos player may need to be reset. Disconnect the power cord for 5 seconds, and then reconnect. Wait for the 

Sonos player to restart.

Not all rooms are visible, or Sonos app doesn’t work in some rooms, or music 
stops when I use my 2.4 GHz phone

You are probably experiencing wireless interference. You can change the wireless channel your Sonos system is operating on 
by following the steps below. 

• Using a handheld Sonos controller: From the Settings menu, touch Advanced Settings -> Wireless Channel. Choose 
another wireless channel from the list.

• Using the Sonos Controller App for PC: Select Settings -> Advanced from the Manage menu. On the General tab, select 
another wireless channel from the list. 

• Using the Sonos Controller App for Mac: Select Preferences -> Advanced from the Sonos menu. On the General tab, 
select another wireless channel from the list.

It may take several seconds for the switch to take effect. If you have music playing, a short music dropout may occur during 
the wireless channel change.

I have a new router

If you purchase a new router or change your ISP (Internet service provider), you will need to restart all your Sonos products 
after the router is installed. 

Note:  If the ISP technician connects a Sonos product to the new router, you only need to 
restart your wireless Sonos products.

1. Disconnect the power cord from all of your Sonos products for at least 5 seconds.

2. Reconnect them one at a time, starting with the Sonos product that is connected to your router.

Wait for your Sonos products to restart. The status indicator light will change to solid white on each product when the 
restart is complete.

If your Sonos setup is completely wireless, you will also need to change your wireless network password. Follow the steps 
below:

1. Temporarily connect one of your Sonos players to the new router with an Ethernet cable.

2. From the Sonos music menu on your controller, select Settings.

3. Select Advanced Settings -> Wireless Setup.

Sonos will detect your network. 
4. Enter the password for your wireless network.

5. Once the password is accepted, unplug the player from your router and move it back to its original location.
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I want to change my wireless network password

If your Sonos system is set up wirelessly and you change your wireless network password, you will also need to change it on 
your Sonos system.

1. Temporarily connect one of your Sonos players to your router with an Ethernet cable.

2. Choose one of the following options:

• Using a handheld Sonos controller, select Settings -> Advanced Settings -> Wireless Setup.
• Using the Sonos Controller App for PC, select Settings -> Advanced from the Manage menu. On the General tab, select 

Wireless Setup.
• Using the Sonos Controller App for Mac, select Preferences -> Advanced from the Sonos menu. On the General tab, 

select Wireless Setup.
3. Enter the new wireless network password when prompted.

4. Once the password is accepted, you can unplug the player from your router and move it back to its original location.
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Player Status Indicators
Important Note: Do not place any items on top of your Sonos player. This may impede the 
air flow and cause it to overheat. 

Indicator Lights Player State Sonos Product Additional Information

Solid white Powered up and associated with a 
Sonos system

BRIDGE, BOOST, 
CONNECT, SUB, 
CONNECT:AMP, DOCK, 
PLAY:1, PLAY:3, PLAY:5, 
PLAYBAR

If desired, when the product is in normal operation, 
you can turn the white status indicator light on or off 
by selecting White Status Light from the Room 
Settings menu. 
(The SUB indicator will reflect the same setting as 
the player it is paired with.)

Flashing white Powering up BRIDGE, BOOST, 
CONNECT, SUB, 
CONNECT:AMP, DOCK, 
PLAY:1, PLAY:3, PLAY:5, 
PLAYBAR

Flashing green Powered up, not yet associated with 
a Sonos system

BRIDGE, BOOST, 
CONNECT, SUB, 
CONNECT:AMP, DOCK, 
PLAY:1, PLAY:3, PLAY:5, 
PLAYBAR

For a SUB, this may indicate the SUB is not yet paired 
with a player.

Solid green Volume set to zero or muted CONNECT, 
CONNECT:AMP, PLAY:1, 
PLAY:3, PLAY:5, 
PLAYBAR

Slowly flashing green Surround audio is off or 
SUB audio is off

PLAY:1, PLAY:3, SUB Applicable for player configured as a PLAYBAR 
surround speaker, or for a SUB paired with a PLAYBAR

Solid orange During wireless setup, this occurs 
while the Sonos open access point is 
temporarily active. 
If you are not setting up your Sonos 
system, this may indicate warning 
mode.

CONNECT, SUB, 
CONNECT:AMP, PLAY:1, 
PLAY:3, PLAY:5, 
PLAYBAR

If the orange light is on AND the player’s volume 
level automatically reduces, this indicates the player 
is in warning mode.

• Press the Pause button to stop the audio
• Check the vent slot for adequate cooling
• Check the room temperature to make sure it’s 

less than 104°F/ 40° C
• If the player is in direct sunlight, provide 

shade
• Allow the player to cool for several minutes 

and then press Play to restart the audio
• If the problem does not resolve, please 

contact Customer Support
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After upgrading Windows, music doesn’t play

After you upgrade from Windows Vista to Windows 7 or 8, you may experience problems playing the music stored on the 
recently updated computer. To ensure uninterrupted play, you'll need to re-add the music folders stored on that computer to 
your Sonos system. 

1. Select Manage -> Settings (PC) or Sonos -> Preferences (Mac).

2. Select Music Library Settings. 

3. On the Folders tab, highlight the shared folder you want to remove, and click Remove (PC) or  (Mac). 

4. Confirm that you want to delete the shared folder.

5. Repeat until you have removed all of the folders.

6. Next, re-add the share by selecting Add (PC) or  (Mac).

7. Select In another location on my computer, or on an external drive connected to my computer, and then click Next.

8. Select the music folder you just removed, and click Next.

Rapidly flashing 
orange

Playback / Next Track failed CONNECT,
CONNECT:AMP, PLAY:1, 
PLAY:3, PLAY:5, 
PLAYBAR

Indicates either playback or next track was not 
possible

Flashing orange During SonosNet setup, this occurs 
after a button press while the 
product is searching for a household 
to join.

BRIDGE, BOOST, 
CONNECT, SUB, 
CONNECT:AMP, DOCK, 
PLAY:1, PLAY:3, PLAY:5, 
PLAYBAR

Slowly flashing orange 
and white

Fault mode CONNECT, 
CONNECT:AMP, PLAY:1, 
PLAY:3, PLAY:5, 
PLAYBAR, SUB

If the lights are flashing orange and white AND the 
volume automatically mutes, this indicates the 
player is experiencing a fault condition.

• Press the Pause button to stop the audio
• Check the room temperature to make sure it’s 

less than 104°F/40° C
• If the player is in direct sunlight, provide 

shade
• Allow the product to cool for several minutes 

and then press Play to restart the audio
• If the problem does not resolve, please 

contact Customer Support

Indicator Lights Player State Sonos Product Additional Information
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Poor quality playback on my Android device

If you notice problems with playback quality it may be because you are streaming large amounts of data, such as video, to an 
Android device that is connected to SonosNet. Try removing the devices from SonosNet to see if the playback quality 
improves.
Remove a single Android device from SonosNet

1. From the Settings menu, touch Advanced Settings. 

2. Touch Connect to SonosNet, and then touch Next.

3. Clear the Allow Connection option. If the option is checked, the controller can connect to SonosNet.

4. Touch Done.

Remove all of your Android devices from SonosNet:

1. From the Settings menu, touch Advanced Settings. 

2. Select Reset SonosNet Key -> Reset. 

The Android devices will connect through the wireless networks that are available to them. If you want the controllers to 
connect to SonosNet again, simply add them back one at a time.

Add Android devices to SonosNet

If you want to reconnect your controllers to SonosNet, add them back one at a time by following the steps below.

1. Select Settings -> Advanced Settings from the Sonos music menu.

2. Touch Connect to SonosNet, and then follow the on-screen prompts.

About Your Music System
If you call Sonos Customer Support, you may be asked for specific details regarding your Sonos system. You can find this 
information by choosing one of the following options:

• Select About My Sonos System from the Settings menu on a handheld controller.
Or,

• Select About My Sonos System from the Help menu on the Sonos Controller for PC.
Or,

• Select About My Sonos System from the Sonos menu on the Sonos Controller for Mac.

Can’t Find What You’re Looking For?
If you can’t find the answer to your question in our documentation, please visit our Frequently Asked Questions (FAQ) pages 
at www.sonos.com/support.
Or, ask us a question at http://faq.sonos.com/ask.

http://www.sonos.com/support
http://faq.sonos.com/ask
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Regulation Information
USA

This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to part 15 of the FCC 
Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation. 
This equipment generates, uses and can radiate radio frequency energy and, if not installed and used in accordance with the 
instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will 
not occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which 
can be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or 
more of the following measures: 

• All Sonos devices have in-products antennas. Users cannot reorient or relocate the receiving antenna without 
modifying the product 

• Increase the separation between the equipment and receiver.
• Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.

Caution: Modifications not expressly approved by the manufacturer may void the user's authority to operate the equipment 
under FCC rules.
The device for operation in the band 5150-5250 MHz is only for indoor use to reduce the potential for harmful interference to 
co-channel mobile satellite systems.

Canada

This Class B digital apparatus complies with Canadian ICES-003 and RSS-210. Operation is subject to the following two 
conditions: (1) this device may not cause interference, and (2) this device must accept any interference, including 
interference that may cause undesired operation of the device. 
The installer of this radio equipment must ensure that the product is located such that it does not emit RF field in excess of 
Health Canada limits for the general population; consult Safety Code 6, obtainable from Health Canada’s Web site 
www.hc-sc.gc.ca/rpb. As mentioned before, the installer cannot control the antenna orientation. However, they could place 
the complete product in a way that causes the problem mentioned above.
The device for operation in the band 5150-5250 MHz is only for indoor use to reduce the potential for harmful interference to 
co-channel mobile satellite systems.
Be advised that high-power radars are allocated as primary users (i.e. priority users) of the bands 5250-5350 MHz and 5650-
5850 MHz and that these radars could cause interference and/or damage to LE-LAN devices.

Canada

Cet appareil numérique de classe B est conforme aux normes NMB-003 et CNR-210 en vigueur au Canada. Son 
fonctionnement est soumis aux deux conditions suivantes : (1) Cet appareil ne doit pas créer d'interférences nuisibles. (2) 
Cet appareil doit tolérer toutes les interférences reçues, y compris les interférences pouvant entraîner un fonctionnement 
indésirable. 
L'installateur du présent matériel radio doit veiller à ce que le produit soit placé ou orienté de manière à n'émettre aucun 
champ radioélectrique supérieur aux limites fixées pour le grand public par le ministère fédéral Santé Canada ; consultez le 
Code de sécurité 6 sur le site Web de Santé Canada à l'adresse : www.hc-sc.gc.ca/rpb. Comme indiqué auparavant, 
l'installateur ne peut pas contrôler l'orientation de l'antenne. Il peut néanmoins placer le produit tout entier de manière à 
provoquer le problème décrit ci-dessus.
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Les dispositifs fonctionnant dans la bande 5150-5250 MHz sont réservés uniquement pour une utilisation à l'intérieur afin de 
réduire les risques de brouillage préjudiciable aux systèmes de satellites mobiles utilisant les mêmes canaux.
Les utilisateurs de radars de haute puissance sont désignés utilisateurs principaux (c.-à-d., qu'ils ont la priorité) pour les 
bandes 5250-5350 MHz et 5650-5850 MHz et que ces radars pourraient causer du brouillage et/ou des dommages aux 
dispositifs LAN-EL.

Europe

Sonos declares that this product herewith complies with the requirements of the EMC Directive 2004/108/EC, Low Voltage 
Directive 2006/95/EC, Eco-Design Directive 2005/32/EC, RoHS Directive 2011/65/EU and the R&TTE Directive 1999/5/EC 
when installed and used in accordance with the manufacturer's instructions. A copy of the full Declaration of Conformance 
may be obtained at www.sonos.com/support/policies.

Attention In France, operation is limited to indoor use within the band 5150-5350 MHz. 
SonosNet is the propriety wireless mesh network architecture designed to provide robust transmission of high fidelity 
streaming digital music. All Sonos players within the SonosNet mesh network act as both a client and access point 
simultaneously. Each Sonos player expands the range of SonosNet mesh network because while each device must be within 
range of at least one other Sonos player, they do not need to be within range of a central access point.  In addition to 
extending the range between Sonos products, SonosNet can extend the range of other data networking devices within the 
home, such as Android devices directly connected to SonosNet. Due to the high network availability requirements of the 
SonosNet mesh network, Sonos players do not have a standby or off mode other than removing the power cord from the AC 
mains.

RF Exposure Requirements

To comply with FCC and Industry Canada exposure essential requirements, a minimum separation distance of 20cm (8 
inches) is required between the equipment and the body of the user or nearby persons.

Recycling Information

This symbol on the product or on its packaging indicates that this product shall not be treated as household waste. 
Instead please deliver it to the applicable collection point for the recycling of electrical and electronic equipment. By 
recycling this product correctly, you will help conserve natural resources and prevent potential negative environmental 
consequences. For more detailed information about recycling of this product, please contact your local city office, your 
household waste disposal service or the shop where you purchased the product.
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